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PLEASE, FIRST READ ALL THIS MANUAL, MAYBE PRINT IT FOR QUICK REFERENCE, THEN USE THE BOARD!!!
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INTRODUCTION

The MadExp HV is a 5V to 900V step-up converter. It is specifically designed as power supply and pulse
counter for Geiger tubes or PMT tubes. It’s output voltage is selectable via 4-bit parallel interface or
jumpers.

TECH SPECS

e Size: 46x50mm

e Weight: <15 grams with OLED

e Input: 5V stabilized @ 10mA with OLED (much lower current without)
e Qutput short circuit current @ 200V: 16pA

e Qutput short circuit current @ 900V: 75pA

e Built-in 10MQ anode loading resistor for Geiger

e Built-in but excludible cathode pulse sensing/conditioning circuit
e 4-bit parallel interface for voltage selection.

e 4-bit jumpers for voltage selection

e UART interface for data logging

e 0.96" OLED display as optional

e open source firmware Arduino compatible

e JTAG interface for firmware loading

For higher output current, you can replace the output limiting resistor R18. Change it from the default
10MQ to minimum 1MQ.

Many Geiger tubes need a greater anode resistor than 10MQ so, in this case, you can put in series with the
tube a resistor of the needed value.

CAUTION! This device generates high voltage. Output current is within few pA; it’s limited by a 10MQ safety resistor.
Take care that the two big ceramic capacitors on the PCB could store enough energy to give you a nice kick if you
touch them during operation.

NEVER TOUCH THE BOARD WHEN ACTIVE. NEVER RUN THE CONVERTER AT MORE THAN 500V WITHOUT AN OUTPUT
LOAD. NEVER DETACH THE OUTPUT LOAD WHEN POWERED, IT COULD GENERATE AN OUTPUT SPIKE THAT WILL
DESTROY THE PULSE SENSING TRANSISTOR. TAKE CARE OF THE CIRCUIT POWER SUPPLY INPUT POLARITY, THERE IS NO

POWER SUPPLY INVERSION PROTECTION. THE OUTPUT VOLTAGE COULD GENERATE A SPARK, USING IT IN EXPLOSIVE
GAS/AIR/DUST/OIL MIXTURE ENVIROMENT IS VERY DANGEROUS! PACEMAKER PATIENTS MUST USE SPECIAL CARE
USING THIS DEVICE. THIS IS NOT A TOY. YOUR FINGERS COULD MAKE AN ELECTROSTATIC DISCHARGE ON THE
BOARD’S CPU IF IT TOUCHES THE BOARD DURING OPERATION, IT COULD DESTROY IT. SAME THING FOR THE OLED
DISPLAY. PLEASE, FIRST READ ALL THIS MANUAL, MAYBE PRINT IT FOR QUICK REFERENCE, THEN USE THE BOARD!!!
THIS CIRCUIT FEAR THE AIR MOISTURE. PLEASE DON’T OPERATE IN HIGH MOISTURE CONTENT AT OUTPUT VOLTAGE




EXCEEDING 450V. AT 900V TOO MUCH MOISTURE IN THE AIR COULD SHORT CIRCUIT THE OUTPUT FILTER
CAPACITORS.

VOLTAGE SELECTION JUMPERS

On the back of the board, there are four voltage selection jumpers.
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A blob of solder that shorts the PCB’s pads making short circuit makes a solder bridge. You'll need a low
power soldering iron and some solder to do this. Take care to do not make short circuits between near
jumpers pads and to not overheat the board.

Take a look at the table and make your jumpers selection accordingly.

JUMPERS DECIMAL OUTPUT

1 2 3 4

0O O 0 0 0 200V
0O O 0 X 1 250V
0O O X 0 2 300V
0O O X X 3 350V
0 X 0 0 4 400V
0 X 0 X 5 450V
0 X X 0 6 500V
0 X X X 7 550V
X 0 0 0 8 600V
X 0 0 X 9 650V
X 0 X 0 10 700V
X 0 X X 11 750V
X X 0 0 12 800V
X X 0 X 13 850V
X X X 0 14 900V
X X X X 15 950V

X = BRIDGE 0 = OPEN

Please note that in order to drive the voltage selection via an external MCU/CPU/microcontroller, all
jumpers must be left open.



CONNECTION DIAGRAM

There are three pin strip on the board.
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The JTAG connector is used to program the MCU with the firmware.

During normal operation it’s used to output serial UART data. 9600bit 8-N-1 no flow control. You can
change it in the firmware and also pin 4 (Arduino D12) remains free for custom firmware use.

JTAG for programming pinout JTAG during normal operation
1. GND 1. GND
2. /RESET 2. /RESET MCU reset if grounded
3. SCK 3. UARTRX
4, MISO 4. Free
5. MOSI 5. UARTTX

The OUT connector is used to output high voltage and input pulses from a Geiger tube or photomultiplier
tube.

e -isthe board ground
e QUT is the high voltage output
e +isthe cathode/pulse input from the Geiger tube. IT IS NOT THE HIGH VOLTAGE OUTPUT
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You can use OUT and — to power your own circuit or OUT and + to directly drive a Geiger tube.
In that case the MCU will count pulses and show counts per minute on the OLED display.

not connected

Geiger tube

Geiger's - to board +

Main connector receives power supply from an external 5V voltage regulator, accept the 4-bit parallel data
from an external MCU/CPU, output the voltage pulse from the pulse conditioning circuit and have a multi-
purpose pin marked as ACK.

Main connector pinout:
1. Pulse out from pulse conditioning circuit
GND
+5Vcc input @10mA minimum. Not protected from polarity inversion!
4-bit interface pin 1 MSB
4-bit interface pin 2
4-bit interface pin 3
4-bit interface pin 4 LSB
Multi-purpose pin ACK

O N Uk WN

» Output pulse on the pin number 1 is obtained by amplifying the incoming pulse from the Geiger
tube, squaring it and expanding the signal.
Output pulse is negative. If you need to count it with external hardware, consider its polarity.
You can modify R8 decreasing it if you have noise issues. A typical noise issue on pulse counting
circuit make the counter counting without any load attached to the output. I've fixed this adding a
100pF capacitor (not present into the schematic) near the Atmega-328. It goes in parallel to the
interrupt pin to ground and it loads the line that comes from the squaring transistor that is present
on the back of the board. With this fix, that is applied on all boards, there is no need to change R8
resistor at all. It works on the complete output voltage range.
If your external counting circuit have some trouble with the pulse generated by the board, you can
consider replacing resistor R10 on the back of the board with a little value like 22kQ or maybe 10kQ.
This ensures high current flow to the transistor making it capable to drive your external counter
better.



This is the Arduino interrupt routine for catching such pulse; “pulse_count” is the global variable that
increment at each pulse. A software timer reset it each 60 seconds.

void setup() {

pinMode (interruptPin, INPUT) ;

attachInterrupt (digitalPinToInterrupt (interruptPin), countPulse, FALLING)
}

void countPulse ()
{
detachInterrupt (interruptPin) ;
pulse count++;
attachInterrupt (digitalPinToInterrupt (interruptPin), countPulse, FALLING)

}

» GND power, supplies main ground, it is pin number 2. Logic and supply grounds are in common:
simply there is only one ground.

» +5Vcc input pin number 3 is the power supply input pin. You'll feed the board connecting your
power supply to it (and GND too). The board is not protected by polarity inversion. There is no
voltage regulator on the board, so you simply must provide on this pin 5V. Not more, not less.
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» The 4-bit parallel interface could be attached directly to an Arduino board or Raspberry or custom
board. Please note that the interface is active low. Logic “true” or “1” is pin short to ground. Logic
“false” or “0” is pin left floating. Floating equals 0 because the onboard MCU have some low
current pull-up resistors active on the interface. They tight each pin to +5V.

» ACK pin is connected to Atmega328 ADC6 or as per Arduino, A6 analog ADC input. It is configured
as digital output active high that signals when the converter reach the selected output voltage.
Could be configured, changing firmware, as analog input. You can use it, for example, as analog
input to sample a battery voltage.
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R8 resistor position 1



FIRST POWER UP

Follow this brief list to power up the board for the first time.

You'll need:
» Soldering iron with some solder
» A 5Vcc power supply
» A Geiger tube

Let’s start:
1. Choose the needed voltage for your Geiger tube. For example, the SBM20 need 400V.
By the table in the section “Voltage selection jumpers” you know that you must make a solder
bridge on jumper number 2 to select that output voltage. Make it, but, take care to not overheat

the board. Pay attention to not make short circuits between adjacent jumper pads.

2. Connect the Geiger tube and take care to respect your tube’s polarity

Geiger tube

not connected

3. Connect your power supply to 5V pin and GND pin. Pay attention to do not reverse polarity.
4. If everything is ok the display must show a logo then the firmware starts rising up output voltage
and counting up incoming pulses from the tube.
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CUSTOM FIRMWARE INFO
Copyright © 2018 Papadopol Lucian www.madexp.com

The firmware of Madexp HV board is provided as Open Source software. You can modify it using Arduino
IDE 1.8.3
To program the board with a USBisp/USBasp or other ATmega compatible programmer, you must follow
this connection diagram:
JTAG connector on the board

1: GND

2: /Reset

3: SCK

4: MISO

5: MOSI
You can create the binary file to be flashed directly on Arduino IDE.

Board setup for the IDE:

Tools>Board—=>Arduino Nano
Tools—>Processor->ATmega328

Then you can create the firmware with:

Sketch—>Export compiled binary

You'll find your *.hex file into your Arduino project folder.

The "without bootloader" has to be flashed on the IC with a software like

"eXtreme Burner AVR". It is free, search online.

You can also directly program the board from Arduino IDE too.
Select your programming JTAG adapter from:

Tools=>Programmer: and select yours (mine is USP-Asp)
To burn it just press:
Sketch->Uploading using programmer

That's all. Enjoy!



NOTE: FUSE BITS

The MadExp HV board comes to you already programmed but, in the uncommon case that there is the
need to re-upload fuse bits configuration, here you can find more info about the correct fuse bits settings.
Preamble: I've found that | must change ATmega328 fuse bits because, as it exits from factory it’s
configured with the option “low speed internal oscillator” active. This is wrong! MadExp HV uses external
high speed crystal resonator.

File RecentFiles Read Write Erase Chip Settings Tools Help

OE® c c 40O 0

Open Save Reload  Read Al Write All Chip Erase Chip Info Help  FanPage! Donate
I Flash IEEPROM Fuse Bits/Settings

Low Fuse High Fuse Extented Fuse Lock Fuse Calibration
Write Write Write | Write [ write
' 62 0x D9 0x fF Ox fF Ox  FFFFFFOS
[ BitDetits.. | [ BitDetaits... | [ Bt Detas... |
I Read All | \ Write

FACTORY CONFIGURATION IS WRONG!!!

File RecentFiles Read Write Erase Chip Settings Tools Help

.Ev@ o o xOQLO

Open Save 0a Read All  Write All Chip Erase Chip Info Help  FanPage! Donate

EEPROM | Fuse Bits/Settings ‘

Low Fuse High Fuse Extented Fuse Lock Fuse Calibration
[ write [ write [T wWrite [ write [ write
0x fF 0x pa 0x D O FF 0x  FFFFFF95
I Bit Details ... l [ Bit Details ... ] [ Bit Details ... ]

—

THIS IS THE RIGHT CONFIGURATION

"\,
TR

A simple but less correct way than change fuse bits manually is, from Arduino software select Tools=>Burn
Bootloader This will correct the fuse bits but you’ll put also a useless bootloader into the chip.

Correct fuse bits are Low Fuse: OxFF High Fuse: DA Extended fuse: FD Lock fuse: FF Calibration: really
doesn’t matter so much.
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WARRANTY, LIMITATION OF LIABILITY, DISCLAIMER

I’'m trying to provide a product of the best quality. All of my products are tested during production and
until shipping to ensure strict quality control. I’'m not a big commercial corporation, I’'m a guy with a good
lab, all of my products are hand made with proper tooling and skilled craftsmanship. | simply made thing
that still doesn’t exist that a maker, an experimenter or a geek like you and me could need. | wish that
you’ll be fully satisfied but sometimes something could go wrong. As most of my products can be easily
damaged in case of improper handling, reverse polarity voltage input, overloading, short circuit or ESD |
provide only limited conditional warranty. The warranty last 7 days from the receiving of the product

parcel. In this period please test the circuit carefully. PLEASE, FIRST READ ALL THIS MANUAL, MAYBE PRINT IT FOR
QUICK REFERENCE, THEN USE THE BOARD.

For any trouble or question or if you need any help, please contact me at |.i.papadopol@gmail.com

Limitation of Liability

Here as “MadExp.com” is indicated the website owner and maker of the product: Papadopol Lucian loan.
The Purchaser shall accept sole responsibility for using the product and MadExp.com shall not be liable for
any use of the product by the Purchaser. The Purchaser shall hold MadExp.com harmless and fully
indemnified against any claims, costs, damages, loss and liabilities arising out of such use.

MadExp.com is not liable to the Purchaser because of any representation, or any warranty (express or
implied), condition or other term, or any duty in common law, or under the express terms of the Contract,
for : (a) any loss of profit, business contracts, opportunity, goodwill, revenue, anticipated savings,
expenses, costs or similar loss; and/or (b) any indirect, special or consequential loss or damage; and in the
case of either paragraph (a) or (b) above whether caused by negligence, breach of contract, tort, or breach
or statutory duty of MadExp.com, arising out of or in connect with the Contract.

Any other liability of MadExp.com to the Purchaser in contract, tort, negligence, breach of statutory duty
or otherwise arising out of or in connection with the Contract is limited to the Price of the Good.

What is the warranty provided by MadExp.com?

Due to the kind of product | sell, | provide limited conditional.

Warranty is provided to ensure that MadExp.com provides quality products and continue to improve
products against general problems. However due to the kind of products we sell, it’s very easy to blow up
the product due to many reasons like improper signals or power supply etc. We provide conditional
warranty only in case there is genuine fault in the product.

Warranty is provided mainly against un-proper components/parts used in manufacture of the product such
the product does not work properly or un-proper assembling or manufacturing defects.

Also warranty is provided for damage occurred during shipping. In this case customers must contact
MadExp.com within 48 hours after receiving the parcel or else the warranty will be void.

MadExp.com is not responsible for improper installation or users carelessness while handling the products.

How do | claim warranty for the products?

First, | recommend you to go through all documentation provided by MadExp.com for the product and
check that you are using it correctly. In case that the problem still persists, please send an email with
description of testing procedure that you have applied and the results to our email id
l.i.papadopol@gmail.com

Most probably the problem will be solved.

Please do not claim warranty until you are very sure that the product is faulty.

-11 -



If there is any visible problem with the product, please send me a photograph of the defect and | will send
replacement free of cost (in case I’'m convinced that the product is to be replaced under warranty).

If there is any functional problem the customer will need to return the product back to me for testing.
Shipping charges for returning the product is responsibility of the customer. In order to ship the product
back to me, first you must contact me via e-mail and explain what the problems. Ship the product in the
original plastic enclosure; it’s made to protect it.

In case of genuine fault of the product, it will be replaced at the earliest time and shipped back to you free
of cost (including shipping cost).

In case there are no problems, or warranty terms are void, MadExp.com can ask customer to pay shipping
charges for returning the product.

In case the warranty is void due to some reason and the product is not damaged permanently, | can repair
it for free and ask customers to pay shipping charges for returning the product.

Warranty can be claimed only once per order.

My product is out of warranty but not working somehow, can MadExp.com repair my

product?

Yes, for sure. If the warranty is over it doesn't mean that my responsibility towards the sold product is
over. | provide repairing service at repairing parts cost plus the shipping. Customer needs to communicate
by email first before sending the product.

For any questions or suggestions please feel free to contact me.
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Schematic

0.96" OLED 128x64 banggood type
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R1 jumper is for servicing.
Unsolder it and you can power the CPU separately from the switching section. 1is 5, 2 is 4

Pinout sense is inverse on PCB's serigraphy.

10M is 1206 package 500V insulation
others are 0805

R8 is 100K for 450V
22K for 600...700V
10K for 900...950V

(C) 2018 Papadopol Lucian

MADEXP www.madexp.com

Universal HV supply Under GPL v3 License

V2.5 Read LICENCE file included with this
package

www.madexp.com

-13-



